Results 1 to 5 of 5

Thread: Video exporting in Sony Vegas?

  1. #1
    Beginner Jase's Avatar
    Join Date
    Apr 2012
    Location
    England
    Posts
    4

    Default Video exporting in Sony Vegas?

    Hopefully this in the right section.

    Right, well, I've made an animation using maplestory sprites and stuff, recorded the animation with fraps. No problems here...the video looks perfect quality and everything's fine...

    ...But I need to edit the footage, do a bit of tweaking like zooming into the animation and whatnot :3, so I open up Sony Vegas 10, load the video in. Everything seems fine still. I do my editing, put music on it and sounds and whatnot, and finally- exporting.

    I've tried a few exports, but the best one seems to be .WMV (Windows Media Video 11 or something), and it gives good results on filesize and the sound seems fine, but, for some reason...I sorta get a glow around black pixels? (I think it's just black pixels, not sure)

    Here's a screenshot
    whiteglow.jpg

    White glow above the characters mouth and below his eyes. See? >.<
    Now here's a screenshot with the contrast upped a bit, to kinda bring it out a bit more.
    whiteglowcontrasted.jpg

    Notice it now? >.< Whilst editing in Sony Vegas, it's not there. And I use high settings when exporting.
    Any particular ways to get it perfect? I don't mind filesize too much, but yeah. Halp >.<

  2. #2
    Wyatt's Avatar
    Join Date
    May 2009
    Location
    East Coast
    Posts
    2,357

    Default

    Your .WMV bitrate for the video is too low.Even for my 5 minute videos, I always keep it above "6 M" which ends up being about a 60mb file at 720p.
    Make sure your video bitrate, no matter the length, is about 10M 10+. Always.
    The reason the white dots is there, is because the video "quality" is low.
    Hope this helps!

    One more tip: MAKE SURE you disable resample" on your clips. It's a 'blur" that is naturally applied to them. It's to make fast-moving real life objects not so "blurred" with is a stupid idea to me.
    Either way, right-click your clips, go to "Switches" and click "Disable resample". You WOULD need to do this for each clip, but if you click the firs CLIP of your video track, hold shift, and click the last clip, it highlights them all. That way, any clip of the track you right click, will disable resample for all of the highlighted clips.

    Hope this helps!

  3. #3
    Beginner Jase's Avatar
    Join Date
    Apr 2012
    Location
    England
    Posts
    4

    Default

    Ahh that's such useful info, man! Thanks! ^-^

    I went along and switched that resampling switch to "Disabled" on the clips and then went along to render. I still get same white glowy pixel result D: I did my rendering options like so, following your advice (then again, I'm probably just being stupid and missing an important detail )


    (In the Project tab, the video quality is set to "Best")

    Not sure what I'm doing wrong heh. :(

  4. #4
    Wyatt's Avatar
    Join Date
    May 2009
    Location
    East Coast
    Posts
    2,357

    Default

    It might be a glitch, because you're downsizing your footage. If you're using an animation program like Flash, and are using sprites, then downsizing would be fine. However, downsizing video footage (like recording with FRAPS) can cause some glitches. Try to export the video at the native resolution of your footage. Like 1024x768 for MapleStory. (Or 800x600 if you play on that.)

    Let me know how it goes.

  5. #5
    Beginner Jase's Avatar
    Join Date
    Apr 2012
    Location
    England
    Posts
    4

    Default

    I really appreciate the help Wyatt.

    The native resolution of my animation is indeed 640x360 (the size of youtubes' widescreen when not in fullscreen). It's recorded fine with Fraps and the Fraps footage seems perfectly good and has picked up on the res being 640x360 and all seems fine. The preview in Sony Vegas looks fine too, though I have noticed that also when I export, generally most of the colours seem more vibrant than the original footage/Sony Vegas preview. Is there maybe an option, like one of those switches for resampling, that happens upon export that I might be forgetting to turn off? I'm not sure x)

    Edit:
    I figured it out! Taken me weeks to figure this out -.- lol, but uhhm, the "Quality", you has choice between Draft, Good, Preview, Best. I always had it at best, turns out that's the problem- having it at Good removes the glow. Looks like the bitrate matters too, so thanks for that, mate ^.^
    Last edited by Jase; 15th May 2012 at 03:57 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •