Results 1 to 2 of 2

Thread: Sapphire 6870 issue (D:)

  1. #1
    Wyatt's Avatar
    Join Date
    May 2009
    East Coast

    Default Sapphire 6870 issue (D:)

    So, I got my new video card finally .Installed it, and updated the drivers to the latest one. (They came out today.)
    Everything went smooth, and there was no problems. However...

    What now seems like anything made by Bethesda does not want to run on my PC. Skyrim, no matter the settings, is giving me MAYBE 10fps outside. Blurry textures, popping n and out, and is REALLY bothering me. I used the "Detect hardware" button, and it detected it, and set the preset to High. Yeah, there's NO way I'd be playing at 10fps. This card should run it AT LEAST 30fps maxed out...I'm at 800x600, off everything, so it's the game and or a driver issue, not my card.
    Fallout New Vegas seems fine on max, BUT It detects my hardware, and presets it to Low. As if the card was a 4250 mobile...DiRT 3 I get 55fps max settings no problem. Team Fortress and L4d2 max No AA I get 220 fps, but I put AA on 8x to get the fps down to a stable 60. GTA IV is running at about 45fps right now, and that's all I've got for games. I was REALLY looking forward to higher settings in Skyrim, but apparently not. I've tried reinstalling the drivers, too. Restarting my PC, and detecting the hardware. I've got Catalyst COntrol Center set to "Application settings" for the options, and I've tried performance on everything. (Texture, AA, AF, etc.) I'm really disappointed, as i was looking forward to Skyrim again..
    My PC specs are:

    5gb of DDR3 1333mhz RAM.
    Sapphire Radeon 6870 1gb.
    Phenom II x4 975 CPU (3.6ghz quad core..)
    ASUS M4A87TD motherboard.
    Corsair 550watt PSU.

    Is this a driver issue with Bethesda and or AMD? And as I said before. New Vegas detects it, and sets it to low settings ,but if I manually set them to max, it runs fine. (45-70fps)
    I'm on Windows 7 Professional 64-bit, by the way.

    Help? :(

    ---------- Post added at 11:28 PM ---------- Previous post was at 11:15 PM ----------

    Completely uninstalled my drivers, and all of it. redownloaded them, installed them, restarted my PC, and it SEEMS to be o.k. so far. Will give an update soon if it happens again. (Do not close this thread yet, please.)

    ---------- Post added 8th March 2012 at 12:00 AM ---------- Previous post was 7th March 2012 at 11:28 PM ----------

    Update: Found the culprit for Skyrim. For some reason, the INI was forcing 16x AA, which was KILLING my card. Got it on 8x, and it was at 50fps, but AA is not necessary at 1920x1200, so...
    Still curious about New Vegas though. :P

  2. #2
    Daeari Dae314's Avatar
    Join Date
    Jan 2009


    Way to solve your own problems.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts